summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-documentedlist/sphinxcontrib-documentedlist-0.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinxcontrib-documentedlist/sphinxcontrib-documentedlist-0.6.ebuild')
-rw-r--r--dev-python/sphinxcontrib-documentedlist/sphinxcontrib-documentedlist-0.6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-documentedlist/sphinxcontrib-documentedlist-0.6.ebuild b/dev-python/sphinxcontrib-documentedlist/sphinxcontrib-documentedlist-0.6.ebuild
new file mode 100644
index 000000000000..b55b8017c3e2
--- /dev/null
+++ b/dev-python/sphinxcontrib-documentedlist/sphinxcontrib-documentedlist-0.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension to convert a Python list into a generated table"
+HOMEPAGE="https://github.com/chintal/sphinxcontrib-documentedlist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}