summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0.ebuild')
-rw-r--r--dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0.ebuild b/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0.ebuild
deleted file mode 100644
index 98201f217f7c..000000000000
--- a/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-inherit distutils-r1
-
-DESCRIPTION="sphinx extension to support coroutines in markup"
-HOMEPAGE="https://github.com/aio-libs/sphinxcontrib-asyncio"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- ${PYTHON} -m pytest tests || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
-
- distutils-r1_python_install_all
-}