summaryrefslogtreecommitdiff
path: root/dev-python/sphinx_rtd_theme/sphinx_rtd_theme-0.5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinx_rtd_theme/sphinx_rtd_theme-0.5.1.ebuild')
-rw-r--r--dev-python/sphinx_rtd_theme/sphinx_rtd_theme-0.5.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/sphinx_rtd_theme/sphinx_rtd_theme-0.5.1.ebuild b/dev-python/sphinx_rtd_theme/sphinx_rtd_theme-0.5.1.ebuild
new file mode 100644
index 000000000000..5f74a92cb962
--- /dev/null
+++ b/dev-python/sphinx_rtd_theme/sphinx_rtd_theme-0.5.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="ReadTheDocs.org theme for Sphinx"
+HOMEPAGE="https://github.com/readthedocs/sphinx_rtd_theme"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE=""
+
+PDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${PDEPEND}
+ dev-python/readthedocs-sphinx-ext[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ # CI=1 disables rebuilding webpack that requires npm use
+ # yes, that surely makes sense
+ export CI=1
+}