summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-tabs/sphinx-tabs-3.4.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinx-tabs/sphinx-tabs-3.4.1-r1.ebuild')
-rw-r--r--dev-python/sphinx-tabs/sphinx-tabs-3.4.1-r1.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/sphinx-tabs/sphinx-tabs-3.4.1-r1.ebuild b/dev-python/sphinx-tabs/sphinx-tabs-3.4.1-r1.ebuild
deleted file mode 100644
index 27ddebbe3002..000000000000
--- a/dev-python/sphinx-tabs/sphinx-tabs-3.4.1-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Tabbed views for Sphinx"
-HOMEPAGE="
- https://github.com/executablebooks/sphinx-tabs/
- https://pypi.org/project/sphinx-tabs/
-"
-SRC_URI="
- https://github.com/executablebooks/sphinx-tabs/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- dev-python/beautifulsoup4[${PYTHON_USEDEP}]
- dev-python/pytest-regressions[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
-
-EPYTEST_DESELECT=(
- # Unpackaged rinohtype
- tests/test_build.py::test_rinohtype_pdf
-)
-
-src_prepare() {
- # annoying, incorrect version limitations
- sed -i -e '/install_requires/d' setup.py || die
-
- distutils-r1_src_prepare
-}