summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-tabs/sphinx-tabs-3.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinx-tabs/sphinx-tabs-3.1.0.ebuild')
-rw-r--r--dev-python/sphinx-tabs/sphinx-tabs-3.1.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/sphinx-tabs/sphinx-tabs-3.1.0.ebuild b/dev-python/sphinx-tabs/sphinx-tabs-3.1.0.ebuild
new file mode 100644
index 000000000000..36801b75db7d
--- /dev/null
+++ b/dev-python/sphinx-tabs/sphinx-tabs-3.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tabbed views for Sphinx"
+HOMEPAGE="https://github.com/executablebooks/sphinx-tabs"
+SRC_URI="https://github.com/executablebooks/sphinx-tabs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/beautifulsoup[${PYTHON_USEDEP}]
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/sphinx-testing[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+
+python_test() {
+ # Unpackaged rinohtype
+ epytest --deselect 'tests/test_build.py::test_rinohtype_pdf'
+}