summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-press-theme/sphinx-press-theme-0.9.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinx-press-theme/sphinx-press-theme-0.9.1.ebuild')
-rw-r--r--dev-python/sphinx-press-theme/sphinx-press-theme-0.9.1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/sphinx-press-theme/sphinx-press-theme-0.9.1.ebuild b/dev-python/sphinx-press-theme/sphinx-press-theme-0.9.1.ebuild
new file mode 100644
index 000000000000..c6e6e6acbc2f
--- /dev/null
+++ b/dev-python/sphinx-press-theme/sphinx-press-theme-0.9.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN="sphinx_press_theme"
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Sphinx-doc theme based on Vuepress"
+HOMEPAGE="https://github.com/schettino72/sphinx_press_theme"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"