summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-notfound-page
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinx-notfound-page')
-rw-r--r--dev-python/sphinx-notfound-page/Manifest3
-rw-r--r--dev-python/sphinx-notfound-page/metadata.xml14
-rw-r--r--dev-python/sphinx-notfound-page/sphinx-notfound-page-0.4.ebuild20
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/sphinx-notfound-page/Manifest b/dev-python/sphinx-notfound-page/Manifest
new file mode 100644
index 000000000000..ad6603c0085d
--- /dev/null
+++ b/dev-python/sphinx-notfound-page/Manifest
@@ -0,0 +1,3 @@
+DIST sphinx-notfound-page-0.4.tar.gz 5685 BLAKE2B 0bfc6cf98e0731a5cc95f1802dad1e7297ed764a626831b970d75d82ec0f7d6edb45c404851ea13bf38decc39aabf0e3dd6b136714a591e8ab595f11e23e67cd SHA512 56e867e6954f26da498b77e8fa43e8d62961ab33ee9c16d2084745dd54a998df51c7d882a47560196135d2fb4d473f7305ef19b31373bc205f8eaf0d3d4946f0
+EBUILD sphinx-notfound-page-0.4.ebuild 524 BLAKE2B a6755c61f8205c4edcd6b32d370c5b54eff5410f73e3ad79aba114249ccd276278d99d639b3c8f68dbbcf7745ef2c65dc10ff26127e02f68e06078088d3effbf SHA512 4382fe457097e1e153bd23d0ea3da3dd71627359b7f0cefa8b99ba6115e61ef729948d5041f1f780cd2b6519f28a53f74e6c81b83a6b7e94931c624be1f654f0
+MISC metadata.xml 440 BLAKE2B 0a08957b47eac83866fdbfd2fc137fa09413c2f6e4cbe961a0c587cb1604951d76061d41acae0a925a9f1775c785e8dc0808255685c14d88b5543e729052aeca SHA512 84b278d6a84dccb896c1e5c10ff1018ec801ea1a36083896f08629db28e82f8b20be2cad95a13b2ad53ba3751c9f6ba0c8a6367ad9baeb2881d22211793c2671
diff --git a/dev-python/sphinx-notfound-page/metadata.xml b/dev-python/sphinx-notfound-page/metadata.xml
new file mode 100644
index 000000000000..7f94ee92d1e7
--- /dev/null
+++ b/dev-python/sphinx-notfound-page/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ Create a custom 404 page with absolute URLs hardcoded.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.4.ebuild b/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.4.ebuild
new file mode 100644
index 000000000000..8c43245b0561
--- /dev/null
+++ b/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.4.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 python3_7 )
+inherit distutils-r1
+
+DESCRIPTION="Create a custom 404 page with absolute URLs hardcoded."
+HOMEPAGE="https://sphinx-notfound-page.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~x64-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+BDEPEND=""