summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-gallery
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinx-gallery')
-rw-r--r--dev-python/sphinx-gallery/Manifest2
-rw-r--r--dev-python/sphinx-gallery/sphinx-gallery-0.10.0.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/sphinx-gallery/Manifest b/dev-python/sphinx-gallery/Manifest
index ae9ffff92f9c..09b4fe4a1b50 100644
--- a/dev-python/sphinx-gallery/Manifest
+++ b/dev-python/sphinx-gallery/Manifest
@@ -1,3 +1,5 @@
+DIST sphinx-gallery-0.10.0.tar.gz 6544847 BLAKE2B c7ca0398b4a2c0090a9c6154b7aa068e05d4eef832a756693b07a23902d1c2e54bbcdb19c108a261555a12646b6fc5fa2314e0337ad8637c4d63173338189054 SHA512 9aa56966ec137f678187383440c0949fb1f91e88c66ad297efd48329627b9891c2d668a2472b071d9352cc22d717e41a5088884fa89a26707c5399dca7cc7237
DIST sphinx-gallery-0.9.0.tar.gz 6530860 BLAKE2B 925a745a9bedaa98cf03fbd66bdb87e5c147543a21944d827f738ea1a8bc657a01f0eba2fa5abe64f7bd3632bef604d9490740f2b6fe5100bba92aeb93f3eaf3 SHA512 e511100c5add06de681b0682c90b3e914d49625c63391896dfdec8e6f6f378cfc65fc3425d4216ee0ebbdd4feb3397517ca40a838947b31257654fff2b8a7e8a
+EBUILD sphinx-gallery-0.10.0.ebuild 1057 BLAKE2B d9610f89dda4d6ceaae91bf44259d4a0d1f31b567bc32496bb706246aa2951167fa9fd6bd3640373cd03bc232ff14141013ce339c988ff1e10acf299d0b2e3c2 SHA512 2f4f7e138a90923cd582ac6783cfce5d5f2fd85ff86ebe86928c3f6af83159d71a09356a7e7a6c015ecf39a87b33a6f3240a452bee15842f46ebb158f6d11ae7
EBUILD sphinx-gallery-0.9.0.ebuild 1115 BLAKE2B f981d3ae9bbcb2e8bc66cb04f908da54b84c27b37b3ff3448e7d6bfe5225ad2913de49a28ed2ed0bbcab413b3d701853964f0f3bf96fbba04ce6694ae1e03557 SHA512 72576a4da31d63d3048184c5940479ffbd02305d8067f53750fadeaf741e0e5c3fb017804b9c3087af831fab8f4af79bc9b0a976dad1699b4bdf1e8b3f538924
MISC metadata.xml 424 BLAKE2B 4e5cd1e912fd5934c7221d3e5cc60b2894eca6b994384f6ceb8397ce9c5312be1e9869b57f9dd7f3ac66501b20e6fd6abd2f33b5d19b93d3a12f7158ba08e7c6 SHA512 17acc19bf43dbbf1a377949576252f77fd334ddd8a3bec593d2339db5a44e4fde831f9ce47be97318bf72e30a062608f883e48cf572904b3476fde0df33adb09
diff --git a/dev-python/sphinx-gallery/sphinx-gallery-0.10.0.ebuild b/dev-python/sphinx-gallery/sphinx-gallery-0.10.0.ebuild
new file mode 100644
index 000000000000..01bce9304f3b
--- /dev/null
+++ b/dev-python/sphinx-gallery/sphinx-gallery-0.10.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension to automatically generate an examples gallery"
+HOMEPAGE="
+ https://sphinx-gallery.github.io/
+ https://github.com/sphinx-gallery/sphinx-gallery"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/joblib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov-report= --cov=sphinx_gallery::' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+EPYTEST_DESELECT=(
+ # Internet
+ sphinx_gallery/tests/test_docs_resolv.py::test_embed_code_links_get_data
+ sphinx_gallery/tests/test_full.py::test_run_sphinx
+ sphinx_gallery/tests/test_full.py::test_embed_links_and_styles
+)