summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-autoapi
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinx-autoapi')
-rw-r--r--dev-python/sphinx-autoapi/Manifest2
-rw-r--r--dev-python/sphinx-autoapi/sphinx-autoapi-3.0.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/sphinx-autoapi/Manifest b/dev-python/sphinx-autoapi/Manifest
index 8aa1d2bc045c..3eba6eed1989 100644
--- a/dev-python/sphinx-autoapi/Manifest
+++ b/dev-python/sphinx-autoapi/Manifest
@@ -1,3 +1,5 @@
DIST sphinx-autoapi-2.1.1.gh.tar.gz 86463 BLAKE2B 412a2c35bfddeb951de66648f39416bfed98ef357e540bf7fd85c4b6962cc97145519b98f87ea207580cb69c1b03260eedfb4872a389cd2dfe56bfe9c9868e46 SHA512 ec562b89f09b7b42cee283e471ab464e07f071f694fdd906984befab5669bcbe7c5d26e7aa2a81d9c64210680408998cbeade6cd8f6a988c3604e3846160ab2d
+DIST sphinx-autoapi-3.0.0.gh.tar.gz 62951 BLAKE2B 80c1168b7d6f2d8489139d1daaa00817bf88345b92d962d1b7114ffd078dab5babd00f3837b9a80bd7175f07a50a432be4096140ac3ee8db11d90e1b836cd308 SHA512 fece7ff76de1ad4a58d8128d7c1f4c57a91ffbc2fb788f7bf4ce230860e97279f8ddf32d24dee4b961d89807056abd2f621484ff91e13b98b57d7f7a00d1cd4c
EBUILD sphinx-autoapi-2.1.1.ebuild 1162 BLAKE2B e3f2447bbc010a081a8244615dd465cc62a24d7bd16cf957cd2f8b89c8472e71c4913e70394ac82e06535d13dc2f66b215a525d7758073b959f7babc6d31b7a5 SHA512 0e8b71527514b304958b866c3e6c2e9f72d04cae66f4cc74ddb733d02fe99e76a2581d5cbb2619e640bae3606e1f9ce7f238747debb5b001f7dbb0b7ea50fdc9
+EBUILD sphinx-autoapi-3.0.0.ebuild 1176 BLAKE2B 1654d7d1362a25a46e20b2a8cf54d3b3ccaf80adc4cfedba8ab68b71b9d3d94a167c64a7b3c989ea9a9034e032bf9dcf3000614c538efa1a096ef634b1d7bd4b SHA512 812b795d3d8a133bd326170b6ca9723df5903ec255a93237d6ebd5b8d3ff2514c64abffd4ac9e965cbfdd145c7b093958235f2e387a3303e9e4cd21ce5c5da2e
MISC metadata.xml 769 BLAKE2B 6f85e487a2d2def289bb54a6addc2338bb8af85b323ec1c95851945f9c407ec22bfadd8079ac8b6e00cfbc85caa0e2b09d82329f1f87a365fc44b69c7bcd9a20 SHA512 68f02a5f98234c2a5cb15aa04ce90077b154a7e3a7a69dc0a1d0a6b5c7b42c60624878a7e2fff1576c8b586fc15e7ef042942274d4e8473835bb3d8bfdbd8393
diff --git a/dev-python/sphinx-autoapi/sphinx-autoapi-3.0.0.ebuild b/dev-python/sphinx-autoapi/sphinx-autoapi-3.0.0.ebuild
new file mode 100644
index 000000000000..a127387bece1
--- /dev/null
+++ b/dev-python/sphinx-autoapi/sphinx-autoapi-3.0.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A new approach to API documentation in Sphinx"
+HOMEPAGE="
+ https://sphinx-autoapi.readthedocs.io/
+ https://github.com/readthedocs/sphinx-autoapi/
+ https://pypi.org/project/sphinx-autoapi/
+"
+# sdist is missing docs, as of 2.1.0
+SRC_URI="
+ https://github.com/readthedocs/sphinx-autoapi/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/anyascii[${PYTHON_USEDEP}]
+ >=dev-python/astroid-3.0.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-6.1.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND+="
+ test? ( dev-python/beautifulsoup4[${PYTHON_USEDEP}] )
+"
+
+DOCS=( README.rst CHANGELOG.rst )
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/python/test_pyintegration.py::TestPipeUnionModule::test_integration
+ "tests/test_integration.py::TestExtensionErrors::test_extension_setup_errors[dotnetexample"
+ )
+
+ distutils-r1_python_test
+}