summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-autoapi/sphinx-autoapi-2.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinx-autoapi/sphinx-autoapi-2.1.1.ebuild')
-rw-r--r--dev-python/sphinx-autoapi/sphinx-autoapi-2.1.1.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/sphinx-autoapi/sphinx-autoapi-2.1.1.ebuild b/dev-python/sphinx-autoapi/sphinx-autoapi-2.1.1.ebuild
deleted file mode 100644
index 302d0863bb9e..000000000000
--- a/dev-python/sphinx-autoapi/sphinx-autoapi-2.1.1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="A new approach to API documentation in Sphinx"
-HOMEPAGE="
- https://sphinx-autoapi.readthedocs.io/
- https://github.com/readthedocs/sphinx-autoapi/
- https://pypi.org/project/sphinx-autoapi/
-"
-# sdist is missing docs, as of 2.1.0
-SRC_URI="
- https://github.com/readthedocs/sphinx-autoapi/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 x86"
-
-RDEPEND="
- dev-python/anyascii[${PYTHON_USEDEP}]
- dev-python/astroid[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- >=dev-python/sphinx-6.0[${PYTHON_USEDEP}]
-"
-
-BDEPEND+="
- test? ( dev-python/beautifulsoup4[${PYTHON_USEDEP}] )
-"
-
-DOCS=( README.rst CHANGELOG.rst )
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Internet
- tests/python/test_pyintegration.py::TestPipeUnionModule::test_integration
- "tests/test_integration.py::TestExtensionErrors::test_extension_setup_errors[dotnetexample"
- )
-
- distutils-r1_python_test
-}