summaryrefslogtreecommitdiff
path: root/dev-python/speg/speg-0.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/speg/speg-0.3-r1.ebuild')
-rw-r--r--dev-python/speg/speg-0.3-r1.ebuild13
1 files changed, 13 insertions, 0 deletions
diff --git a/dev-python/speg/speg-0.3-r1.ebuild b/dev-python/speg/speg-0.3-r1.ebuild
new file mode 100644
index 000000000000..53fe6ac90cba
--- /dev/null
+++ b/dev-python/speg/speg-0.3-r1.ebuild
@@ -0,0 +1,13 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+DESCRIPTION="A PEG-based parser interpreter with memoization"
+HOMEPAGE="https://github.com/avakar/speg/"
+SRC_URI="https://github.com/avakar/speg/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""