summaryrefslogtreecommitdiff
path: root/dev-python/sortedcontainers/sortedcontainers-1.5.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sortedcontainers/sortedcontainers-1.5.7.ebuild')
-rw-r--r--dev-python/sortedcontainers/sortedcontainers-1.5.7.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/sortedcontainers/sortedcontainers-1.5.7.ebuild b/dev-python/sortedcontainers/sortedcontainers-1.5.7.ebuild
new file mode 100644
index 000000000000..2a25c2cc15f5
--- /dev/null
+++ b/dev-python/sortedcontainers/sortedcontainers-1.5.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to sort collections and containers"
+HOMEPAGE="http://www.grantjenks.com/docs/sortedcontainers/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 arm x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -v || die
+}