summaryrefslogtreecommitdiff
path: root/dev-python/snakeoil/snakeoil-0.8.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/snakeoil/snakeoil-0.8.2.ebuild')
-rw-r--r--dev-python/snakeoil/snakeoil-0.8.2.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-python/snakeoil/snakeoil-0.8.2.ebuild b/dev-python/snakeoil/snakeoil-0.8.2.ebuild
deleted file mode 100644
index e85e66b9b7a0..000000000000
--- a/dev-python/snakeoil/snakeoil-0.8.2.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{6,7} )
-PYTHON_REQ_USE="threads(+)"
-inherit distutils-r1
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
- inherit git-r3
-else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-fi
-
-DESCRIPTION="misc common functionality and useful optimizations"
-HOMEPAGE="https://github.com/pkgcore/snakeoil"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )"
-[[ ${PV} == 9999 ]] && DEPEND+=" dev-python/cython[${PYTHON_USEDEP}]"
-
-python_test() {
- esetup.py test
-}