summaryrefslogtreecommitdiff
path: root/dev-python/smartypants/smartypants-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/smartypants/smartypants-9999.ebuild')
-rw-r--r--dev-python/smartypants/smartypants-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/smartypants/smartypants-9999.ebuild b/dev-python/smartypants/smartypants-9999.ebuild
index 418910a52b87..c5c6b78000bf 100644
--- a/dev-python/smartypants/smartypants-9999.ebuild
+++ b/dev-python/smartypants/smartypants-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{6..10} )
-DISTUTILS_USE_SETUPTOOLS=no
MY_PN="${PN}.py"
MY_P="${MY_PN}-${PV}"
@@ -20,7 +20,7 @@ if [[ ${PV} = 9999* ]]; then
inherit git-r3
else
SRC_URI="https://github.com/leohemsted/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86"
S="${WORKDIR}/${MY_P}"
fi