summaryrefslogtreecommitdiff
path: root/dev-python/simplejson
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/simplejson')
-rw-r--r--dev-python/simplejson/Manifest4
-rw-r--r--dev-python/simplejson/simplejson-3.19.2.ebuild2
-rw-r--r--dev-python/simplejson/simplejson-3.19.3.ebuild37
3 files changed, 41 insertions, 2 deletions
diff --git a/dev-python/simplejson/Manifest b/dev-python/simplejson/Manifest
index ca479f3e8920..620df76dfe31 100644
--- a/dev-python/simplejson/Manifest
+++ b/dev-python/simplejson/Manifest
@@ -1,3 +1,5 @@
DIST simplejson-3.19.2.tar.gz 85311 BLAKE2B eecbe77c9612468a0ce52b165be9b4fc4b3d8bcca99621a2723c50fc0c89cdce981421ba71b85535f1c66b48b7178da37f117f9dec8a66cb6f3fe83e3d2d033e SHA512 d92bf617e27b66d93a5d176d38c0c6ae2777728d1e43fdb8054cc9c2b50e3f340079c82dd3ec1af36c8d6380833d16e8eecdc8dd950bba953c195256b44b46c5
-EBUILD simplejson-3.19.2.ebuild 1001 BLAKE2B 429c3bb1368715164dcd973b6457347b5492ec7089fcf8d37c983b52e7a4af128cecb8bf0ca6bf74a26540d0dc54416f1f85c5b2c6a2dadda4274ae01754617c SHA512 3dfbc523cab3e5a4b825e53ee56b35411e2df7702b2142fdcec4e2cf766046518010994aa494bed2357b4e7e1337346c7af540b722d819e4286c8490c1b21fc0
+DIST simplejson-3.19.3.tar.gz 85237 BLAKE2B e3c233201c390a1c864670d9a7a81a6aef5334632afbbc303b31dab06709d8a383451e3c7500be3166282b322b93f4fedc2633a1519cb2e2eaef7c4472e903a6 SHA512 257c10c4c84201f1d9c4d77e823c4ef393bf7214c8947e4c95bcfe7c09140ff1b974cc5b00a6e659961263380673d3c4b67a1b37f878888ed049f1db0b663c92
+EBUILD simplejson-3.19.2.ebuild 995 BLAKE2B cd01d4a46ee343bc37735738e330d1072e5c7f338753ec0203ccb1abcc471cf63a80d2e2a39ae330c26eb29ca744fbf03c6b01cec95df861e6a13848009246d5 SHA512 096fb10b613010a66a00500d33fa4a7e3f106b9dd64efd90dca364101eaab209f86c4ee35db13e70793db120a964fbfdb0a8445b97e695f523358e41eb6a7828
+EBUILD simplejson-3.19.3.ebuild 996 BLAKE2B 17a1809b58587becc82d18b7110268f7003a84004fc62378e930612fe5717cf09055f10c0ebd2256cdfb00fc47e39bac642f86e59333ccae70d90ac59712fed5 SHA512 1322058e3c929a4942d97813addcba8fdb2d6a2025a3b2acae0c17d65f337354d401f1cabcc51c341db82a62742bd41834ae68131fd418012b140c926c87adc0
MISC metadata.xml 522 BLAKE2B b8b8fdade498ef65f4d5d6e30bc9f0708390f3d064a332d04f0b33346224c59252ef3d512a5a7187c637348201829ccc83254cd898e8df06dff314e857debb58 SHA512 1a1b53900ef62d4d40977504378dce3ce15f1c56ae5a73263127f5919674b1f9b13964128550e0c0e274d4bf50f2c2b438626e3ba1a5f8436071e1eb2f4c30af
diff --git a/dev-python/simplejson/simplejson-3.19.2.ebuild b/dev-python/simplejson/simplejson-3.19.2.ebuild
index 78c4ef114cf0..9e93079d36a0 100644
--- a/dev-python/simplejson/simplejson-3.19.2.ebuild
+++ b/dev-python/simplejson/simplejson-3.19.2.ebuild
@@ -17,7 +17,7 @@ HOMEPAGE="
LICENSE="|| ( MIT AFL-2.1 )"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
IUSE="+native-extensions"
DOCS=( README.rst CHANGES.txt )
diff --git a/dev-python/simplejson/simplejson-3.19.3.ebuild b/dev-python/simplejson/simplejson-3.19.3.ebuild
new file mode 100644
index 000000000000..f88902e10e03
--- /dev/null
+++ b/dev-python/simplejson/simplejson-3.19.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="
+ https://github.com/simplejson/simplejson/
+ https://pypi.org/project/simplejson/
+"
+
+LICENSE="|| ( MIT AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="+native-extensions"
+
+DOCS=( README.rst CHANGES.txt )
+
+distutils_enable_tests unittest
+
+src_configure() {
+ # native-extensions are always disabled on PyPy
+ # https://github.com/simplejson/simplejson/blob/master/setup.py#L121
+ export DISABLE_SPEEDUPS=$(usex native-extensions 0 1)
+ use native-extensions && export REQUIRE_SPEEDUPS=1
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ eunittest
+}