summaryrefslogtreecommitdiff
path: root/dev-python/simplegeneric/simplegeneric-0.8.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/simplegeneric/simplegeneric-0.8.1-r1.ebuild')
-rw-r--r--dev-python/simplegeneric/simplegeneric-0.8.1-r1.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/dev-python/simplegeneric/simplegeneric-0.8.1-r1.ebuild b/dev-python/simplegeneric/simplegeneric-0.8.1-r1.ebuild
index 8978530ef627..8ab32da7b1eb 100644
--- a/dev-python/simplegeneric/simplegeneric-0.8.1-r1.ebuild
+++ b/dev-python/simplegeneric/simplegeneric-0.8.1-r1.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
PYTHON_COMPAT=( python3_{7,8} )
inherit distutils-r1
@@ -12,11 +13,8 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
LICENSE="ZPL"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE=""
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-DEPEND="app-arch/unzip"
+BDEPEND="app-arch/unzip"
-python_test() {
- esetup.py test
-}
+distutils_enable_tests setup.py