summaryrefslogtreecommitdiff
path: root/dev-python/simpervisor/simpervisor-0.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/simpervisor/simpervisor-0.4-r1.ebuild')
-rw-r--r--dev-python/simpervisor/simpervisor-0.4-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/simpervisor/simpervisor-0.4-r1.ebuild b/dev-python/simpervisor/simpervisor-0.4-r1.ebuild
new file mode 100644
index 000000000000..086ec03866e8
--- /dev/null
+++ b/dev-python/simpervisor/simpervisor-0.4-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Simple Python3 Supervisor library"
+HOMEPAGE="https://github.com/jupyterhub/simpervisor"
+SRC_URI="https://github.com/jupyterhub/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest