summaryrefslogtreecommitdiff
path: root/dev-python/shellingham/shellingham-1.5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/shellingham/shellingham-1.5.1.ebuild')
-rw-r--r--dev-python/shellingham/shellingham-1.5.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/shellingham/shellingham-1.5.1.ebuild b/dev-python/shellingham/shellingham-1.5.1.ebuild
new file mode 100644
index 000000000000..be6e6357e080
--- /dev/null
+++ b/dev-python/shellingham/shellingham-1.5.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Tool to Detect Surrounding Shell"
+HOMEPAGE="
+ https://github.com/sarugaku/shellingham/
+ https://pypi.org/project/shellingham/
+"
+# Missing tests in PYPI distribution so we use the GH package
+SRC_URI="
+ https://github.com/sarugaku/shellingham/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest