summaryrefslogtreecommitdiff
path: root/dev-python/shapely/files/shapely-2.0.1-cython3.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/shapely/files/shapely-2.0.1-cython3.patch')
-rw-r--r--dev-python/shapely/files/shapely-2.0.1-cython3.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/shapely/files/shapely-2.0.1-cython3.patch b/dev-python/shapely/files/shapely-2.0.1-cython3.patch
new file mode 100644
index 000000000000..23fb0384e3f4
--- /dev/null
+++ b/dev-python/shapely/files/shapely-2.0.1-cython3.patch
@@ -0,0 +1,30 @@
+https://bugs.gentoo.org/898708
+https://github.com/shapely/shapely/pull/1872
+https://github.com/shapely/shapely/commit/fea6d0351a4422b1f9fefb508db7924981c18e43
+
+From fea6d0351a4422b1f9fefb508db7924981c18e43 Mon Sep 17 00:00:00 2001
+From: Joris Van den Bossche <jorisvandenbossche@gmail.com>
+Date: Sun, 8 Oct 2023 11:12:28 +0200
+Subject: [PATCH] Fix for cython 3 compatibility (#1872)
+
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -1,6 +1,6 @@
+ [build-system]
+ requires = [
+- "Cython~=0.29",
++ "Cython",
+ "oldest-supported-numpy",
+ "setuptools>=61.0.0",
+ ]
+--- a/shapely/_geos.pyx
++++ b/shapely/_geos.pyx
+@@ -8,7 +8,7 @@ import warnings
+ from shapely import GEOSException
+
+
+-cdef void geos_message_handler(const char* message, void* userdata):
++cdef void geos_message_handler(const char* message, void* userdata) noexcept:
+ snprintf(<char *>userdata, 1024, "%s", message)
+
+