summaryrefslogtreecommitdiff
path: root/dev-python/sh/sh-2.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sh/sh-2.0.3.ebuild')
-rw-r--r--dev-python/sh/sh-2.0.3.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/sh/sh-2.0.3.ebuild b/dev-python/sh/sh-2.0.3.ebuild
new file mode 100644
index 000000000000..e05aec059c1e
--- /dev/null
+++ b/dev-python/sh/sh-2.0.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python subprocess interface"
+HOMEPAGE="
+ https://github.com/amoffat/sh/
+ https://pypi.org/project/sh/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests unittest