summaryrefslogtreecommitdiff
path: root/dev-python/sh/sh-1.12.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sh/sh-1.12.9.ebuild')
-rw-r--r--dev-python/sh/sh-1.12.9.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/sh/sh-1.12.9.ebuild b/dev-python/sh/sh-1.12.9.ebuild
new file mode 100644
index 000000000000..168127d102d9
--- /dev/null
+++ b/dev-python/sh/sh-1.12.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python subprocess interface"
+HOMEPAGE="https://github.com/amoffat/sh"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}/sh-1.12.9-python2-unicode-tests.patch"
+)
+
+python_test() {
+ ${PYTHON} test.py || die
+}