summaryrefslogtreecommitdiff
path: root/dev-python/sh/sh-1.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sh/sh-1.11.ebuild')
-rw-r--r--dev-python/sh/sh-1.11.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/sh/sh-1.11.ebuild b/dev-python/sh/sh-1.11.ebuild
new file mode 100644
index 000000000000..a4e9e8ae7468
--- /dev/null
+++ b/dev-python/sh/sh-1.11.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=(python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python subprocess interface"
+HOMEPAGE="https://github.com/amoffat/sh"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${PYTHON} test.py || die
+}