summaryrefslogtreecommitdiff
path: root/dev-python/setuptools_trial
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/setuptools_trial')
-rw-r--r--dev-python/setuptools_trial/Manifest2
-rw-r--r--dev-python/setuptools_trial/setuptools_trial-0.6.0-r1.ebuild14
2 files changed, 10 insertions, 6 deletions
diff --git a/dev-python/setuptools_trial/Manifest b/dev-python/setuptools_trial/Manifest
index 401d5faa1a32..eac731ee969c 100644
--- a/dev-python/setuptools_trial/Manifest
+++ b/dev-python/setuptools_trial/Manifest
@@ -1,3 +1,3 @@
DIST setuptools_trial-0.6.0.tar.gz 6227 BLAKE2B 2df7276197a5630b8140dce17528b75045ea86e15495146aceafc4428f6ab6493fbe8e2edfded30ae644523455df02f3cb85e8bf8879bd4fafc9a332d9f6bc40 SHA512 9104b98627f57ed53c90d22042346875c5324d7b30e1ec9ba1718b5c59a786915a8fe0a53789a5dbd9318a12b27122661234f5be403365261db6a8728ce39827
-EBUILD setuptools_trial-0.6.0-r1.ebuild 1286 BLAKE2B 842b10eca732849e12f59b317f9bee15cbe1216fcdd9ad4b06260bd8593bcb674a1708b7e102cfa47415df7ba1856c4c953ab9273ae7538effaa84048da15381 SHA512 e2188be2acf12c7f8aab03e262d62c17b982afedbb37d41210af3f559ad613037082bdcda84a5f216c43b1c7c6d8d61114674bc371e507ed414a612096b4e833
+EBUILD setuptools_trial-0.6.0-r1.ebuild 1393 BLAKE2B 0fbe9660a3d8783b9f4ca87b0f0ae396be1cf0ca2c7cc54650f394692368d550b5c75e798abfa8ce1bf4f8b9901349fe6c39ca9b1c3ed515eeea6e20ffa6c652 SHA512 3842ab92f9da73aff4882a38c5f583d0c06fe4590aea2c1872f9a6811502d6cd12cb6b0941d89f9ff97cc8990eab8323fcbeedff6818e6e2485cf5bdb8121358
MISC metadata.xml 844 BLAKE2B aa1bcc13874420abbdec6f9ad64b6b408f30d30b880d9c57dbeda6a3e01d2427aa3fdf0123b4e15dbcbb0f2b974ad7e3cac9158030be1f5837b3327b878404c6 SHA512 85d7004cfbb15d2137bdaefd573f0fcc4e5b08c8e70a5ac3db3bb961842a62ee7451ccfd9615f3eac1fefd4845a25c7fae650b86f52e9bcf6c38054485ebb6fe
diff --git a/dev-python/setuptools_trial/setuptools_trial-0.6.0-r1.ebuild b/dev-python/setuptools_trial/setuptools_trial-0.6.0-r1.ebuild
index 331289048c42..849cb00d85f1 100644
--- a/dev-python/setuptools_trial/setuptools_trial-0.6.0-r1.ebuild
+++ b/dev-python/setuptools_trial/setuptools_trial-0.6.0-r1.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-DISTUTILS_USE_SETUPTOOLS=bdepend
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Setuptools plugin that makes unit tests execute with trial instead of pyunit"
@@ -22,7 +20,13 @@ RDEPEND="
>=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
"
-BDEPEND="${RDEPEND}"
+BDEPEND="test? ( ${RDEPEND} )"
+
+src_prepare() {
+ # don't install docs into wrong location
+ sed -e '/data_files=/d' -i setup.py || die
+ distutils-r1_src_prepare
+}
python_test() {
distutils_install_for_testing