summaryrefslogtreecommitdiff
path: root/dev-python/setuptools_scm/setuptools_scm-7.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/setuptools_scm/setuptools_scm-7.1.0.ebuild')
-rw-r--r--dev-python/setuptools_scm/setuptools_scm-7.1.0.ebuild23
1 files changed, 17 insertions, 6 deletions
diff --git a/dev-python/setuptools_scm/setuptools_scm-7.1.0.ebuild b/dev-python/setuptools_scm/setuptools_scm-7.1.0.ebuild
index 1efefeb1ff54..b4b66d2a3ea1 100644
--- a/dev-python/setuptools_scm/setuptools_scm-7.1.0.ebuild
+++ b/dev-python/setuptools_scm/setuptools_scm-7.1.0.ebuild
@@ -39,10 +39,21 @@ BDEPEND="
distutils_enable_tests pytest
-EPYTEST_DESELECT=(
- # the usual nondescript gpg-agent failure
- testing/test_git.py::test_git_getdate_signed_commit
+python_test() {
+ local EPYTEST_DESELECT=(
+ # the usual nondescript gpg-agent failure
+ testing/test_git.py::test_git_getdate_signed_commit
- # fetching from the Internet
- testing/test_regressions.py::test_pip_download
-)
+ # fetching from the Internet
+ testing/test_regressions.py::test_pip_download
+ )
+
+ if has_version dev-python/nose; then
+ EPYTEST_DESELECT+=(
+ # https://bugs.gentoo.org/892639
+ testing/test_integration.py::test_pyproject_support
+ )
+ fi
+
+ epytest
+}