summaryrefslogtreecommitdiff
path: root/dev-python/serpent/serpent-1.40.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/serpent/serpent-1.40.ebuild')
-rw-r--r--dev-python/serpent/serpent-1.40.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/serpent/serpent-1.40.ebuild b/dev-python/serpent/serpent-1.40.ebuild
new file mode 100644
index 000000000000..4e40de17c426
--- /dev/null
+++ b/dev-python/serpent/serpent-1.40.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A simple serialization library based on ast.literal_eval"
+HOMEPAGE="https://pypi.org/project/serpent/ https://github.com/irmen/Serpent"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests setup.py