summaryrefslogtreecommitdiff
path: root/dev-python/sentry-sdk
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sentry-sdk')
-rw-r--r--dev-python/sentry-sdk/Manifest4
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-0.20.3.ebuild67
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.0.0.ebuild2
3 files changed, 2 insertions, 71 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index faa687b26cf2..f885fc3616f3 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1,5 +1,3 @@
-DIST sentry-sdk-0.20.3.tar.gz 212130 BLAKE2B 48084039c493ca2903f56426913ea8f8f0480b759157270fe6ea4dfae72f9478d8566f8a86f6f863c06adb01379e980d5f873372f401a8d3f255f62f8a149b45 SHA512 0392fcf0e718f7d06200fa44fedf1aac46a2f61d11a8252ca339652d5385a377545128c1c4b9e31e1e1a8c8c9a8c57ded569b829312a748d84ad98696a897944
DIST sentry-sdk-1.0.0.tar.gz 213707 BLAKE2B 9fa3dfac7d82c9e2c81be6f4edafbc27ab19a2a96876885dabe72d2dbd6cf392b80e453c640affb94d84f35b227b12d56927bec88e01a0ebfdcf8a466470a909 SHA512 e91ede3e5e31c2acba7094bd5c6a95280aa8367b1fcd524fc9b100d2a3a253efec1ed3d9c72465f5b2ef5276c834906d622b84e1650b65d2032f4acaf2fd1ab8
-EBUILD sentry-sdk-0.20.3.ebuild 2129 BLAKE2B de023c5d35c37959a0ab94b11f0d5f4b1d45dc362098fa894c20dccb4fb96603ef11b9224778bb557c82a4ac50735f64f8239999c019c730a2c73997c9678cb8 SHA512 9771cc9b03b1b64bc558498382e3565d5144e9de3db487435adcf08d0c940c252307507f91462837d01df5309bfa3e0b85ab2097bb6214f59efb603e10f52f5a
-EBUILD sentry-sdk-1.0.0.ebuild 2280 BLAKE2B 1eded6b4d30c3973cbc3c9f1e5811803b5a4a2376f3886ae8bf3331dd8fff3c847bccc787fce03258e1f3200812880d12abb03e3fe1fc6a07ca6654935d35960 SHA512 4fb27231fde3b323312072e2eb6d1ca97165d7b27515f7a349e1b54a4ae92d490fd0971cad2229162f32acf7693c8ac0c62d60c470fe7ee3d3bda2006054af4d
+EBUILD sentry-sdk-1.0.0.ebuild 2276 BLAKE2B 728371e10316b4f3e894274fd7167401b87715a317e5d826ea63cd293b8204d1f5a427f1a7ba1071e80d477e71a5710b02e9eb12da7f7633ffaf4507a1648318 SHA512 882c5b8a27083f3a576c7b2dd1c15a8fbf962ba20dd411191374294719778c15cbfa93132807923c4a320eb8ab1d6b390e996b5584d78b9a6c55a67286a70538
MISC metadata.xml 509 BLAKE2B 5b68b368764625061ea2eadc0161570e46760904015f6e1e3e97a7a4dacd3604a18b2cbfb665e816981a40f95ec9c4f0c4a0447ecc968cbdf1fd21dcd4149193 SHA512 c42a1f7972313d3369ba392347b0efa700ee9c9b01d3275b3973b8137cf00fca693288a1af57c355b2d87525d9fcb7a320ad571fe8be5531472a8710f9b287d1
diff --git a/dev-python/sentry-sdk/sentry-sdk-0.20.3.ebuild b/dev-python/sentry-sdk/sentry-sdk-0.20.3.ebuild
deleted file mode 100644
index d3a5fb8d4d3f..000000000000
--- a/dev-python/sentry-sdk/sentry-sdk-0.20.3.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python client for Sentry"
-HOMEPAGE="https://sentry.io/ https://pypi.org/project/sentry-sdk/"
-SRC_URI="https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/sentry-python-${PV}"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~sparc x86"
-
-RDEPEND="
- dev-python/urllib3[${PYTHON_USEDEP}]
- dev-python/certifi[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/asttokens[${PYTHON_USEDEP}]
- dev-python/django[${PYTHON_USEDEP}]
- dev-python/executing[${PYTHON_USEDEP}]
- dev-python/eventlet[${PYTHON_USEDEP}]
- dev-python/fakeredis[${PYTHON_USEDEP}]
- dev-python/flask-login[${PYTHON_USEDEP}]
- dev-python/gevent[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/pyrsistent[${PYTHON_USEDEP}]
- dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
- dev-python/pytest-django[${PYTHON_USEDEP}]
- dev-python/pytest-forked[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # tests require Internet access
- tests/integrations/stdlib/test_httplib.py
- tests/integrations/requests/test_requests.py
- # wtf is it supposed to do?!
- tests/integrations/gcp/test_gcp.py
- # hangs
- 'tests/test_transport.py::test_transport_works[eventlet'
- # TODO
- 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
- tests/test_client.py::test_databag_depth_stripping
- tests/test_client.py::test_databag_string_stripping
- tests/test_client.py::test_databag_breadth_stripping
- # test_circular_references: apparently fragile
- 'tests/integrations/threading/test_threading.py::test_circular_references'
- )
-
- # Prevent tests/integrations/modules/test_modules.py:test_basic failure
- # Needs to detect sentry-sdk in the installed modules
- distutils_install_for_testing
-
- pytest -vv ${deselect[@]/#/--deselect } || die "Tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.0.0.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.0.0.ebuild
index 1c883d192386..b0bc738254e6 100644
--- a/dev-python/sentry-sdk/sentry-sdk-1.0.0.ebuild
+++ b/dev-python/sentry-sdk/sentry-sdk-1.0.0.ebuild
@@ -14,7 +14,7 @@ S="${WORKDIR}/sentry-python-${PV}"
LICENSE="PSF-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~sparc x86"
RDEPEND="
dev-python/urllib3[${PYTHON_USEDEP}]