summaryrefslogtreecommitdiff
path: root/dev-python/send2trash/send2trash-1.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/send2trash/send2trash-1.5.0.ebuild')
-rw-r--r--dev-python/send2trash/send2trash-1.5.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/send2trash/send2trash-1.5.0.ebuild b/dev-python/send2trash/send2trash-1.5.0.ebuild
new file mode 100644
index 000000000000..8d102d20e3e2
--- /dev/null
+++ b/dev-python/send2trash/send2trash-1.5.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} pypy )
+
+inherit distutils-r1
+
+MY_PN="Send2Trash"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Sends files to the Trash (or Recycle Bin)"
+HOMEPAGE="
+ https://pypi.org/project/Send2Trash/
+ https://github.com/hsoft/send2trash"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-broken-tests-on-py2.patch"
+)
+
+python_test() {
+ ${EPYTHON} setup.py test
+}