summaryrefslogtreecommitdiff
path: root/dev-python/semantic_version/semantic_version-2.6.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/semantic_version/semantic_version-2.6.0-r2.ebuild')
-rw-r--r--dev-python/semantic_version/semantic_version-2.6.0-r2.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/semantic_version/semantic_version-2.6.0-r2.ebuild b/dev-python/semantic_version/semantic_version-2.6.0-r2.ebuild
deleted file mode 100644
index c8ebba6b2e3e..000000000000
--- a/dev-python/semantic_version/semantic_version-2.6.0-r2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library providing a few tools handling SemVer in Python"
-HOMEPAGE="https://pypi.org/project/semantic_version/"
-SRC_URI="https://github.com/rbarrois/python-semanticversion/archive/v${PV}.tar.gz -> ${P}-1.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="doc test"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-S="${WORKDIR}/python-${P/_/}"
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs docs/_build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- # The django test hangs
- py.test --ignore tests/test_django.py\
- || die "tests failed with ${EPYTHON}"
-}