summaryrefslogtreecommitdiff
path: root/dev-python/semantic-version/semantic-version-2.10.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/semantic-version/semantic-version-2.10.0.ebuild')
-rw-r--r--dev-python/semantic-version/semantic-version-2.10.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/semantic-version/semantic-version-2.10.0.ebuild b/dev-python/semantic-version/semantic-version-2.10.0.ebuild
new file mode 100644
index 000000000000..f25427331685
--- /dev/null
+++ b/dev-python/semantic-version/semantic-version-2.10.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python library providing a few tools handling SemVer in Python"
+HOMEPAGE="
+ https://github.com/rbarrois/python-semanticversion/
+ https://pypi.org/project/semantic-version/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv ~s390 sparc x86"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p no:django
+}