summaryrefslogtreecommitdiff
path: root/dev-python/seaborn/seaborn-0.13.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/seaborn/seaborn-0.13.2.ebuild')
-rw-r--r--dev-python/seaborn/seaborn-0.13.2.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-python/seaborn/seaborn-0.13.2.ebuild b/dev-python/seaborn/seaborn-0.13.2.ebuild
index b7d3e8825fc5..dec22c29c233 100644
--- a/dev-python/seaborn/seaborn-0.13.2.ebuild
+++ b/dev-python/seaborn/seaborn-0.13.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1 pypi
@@ -30,6 +30,13 @@ RDEPEND="
EPYTEST_XDIST=1
distutils_enable_tests pytest
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # https://github.com/mwaskom/seaborn/pull/3685
+ sed -i -e '/VisibleDeprecationWarning/d' tests/test_distributions.py || die
+}
+
src_test() {
cat > matplotlibrc <<- EOF || die
backend : Agg