summaryrefslogtreecommitdiff
path: root/dev-python/scrypt/scrypt-0.8.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/scrypt/scrypt-0.8.6.ebuild')
-rw-r--r--dev-python/scrypt/scrypt-0.8.6.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-python/scrypt/scrypt-0.8.6.ebuild b/dev-python/scrypt/scrypt-0.8.6.ebuild
index aa80ad170313..c886c88b999c 100644
--- a/dev-python/scrypt/scrypt-0.8.6.ebuild
+++ b/dev-python/scrypt/scrypt-0.8.6.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} pypy )
inherit distutils-r1
@@ -15,8 +16,10 @@ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
SLOT="0"
IUSE="test doc"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-libs/openssl:0="
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
python_test() {
- esetup.py test || die "tests failed"
+ esetup.py test
}