summaryrefslogtreecommitdiff
path: root/dev-python/scipy/scipy-1.9.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/scipy/scipy-1.9.9999.ebuild')
-rw-r--r--dev-python/scipy/scipy-1.9.9999.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/dev-python/scipy/scipy-1.9.9999.ebuild b/dev-python/scipy/scipy-1.9.9999.ebuild
index e2718fe21ca6..06820b113911 100644
--- a/dev-python/scipy/scipy-1.9.9999.ebuild
+++ b/dev-python/scipy/scipy-1.9.9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=meson-python
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
PYTHON_REQ_USE="threads(+)"
inherit fortran-2 distutils-r1 multiprocessing
@@ -38,13 +38,13 @@ else
S="${WORKDIR}"/${MY_P}
if [[ ${PV} != *rc* ]] ; then
- KEYWORDS="~amd64 -hppa ~ppc64 ~riscv"
+ KEYWORDS="~amd64 ~arm64 -hppa ~ppc64 ~riscv"
fi
fi
LICENSE="BSD LGPL-2"
SLOT="0"
-IUSE="doc"
+IUSE="doc +pythran"
# umfpack is technically optional but it's preferred to have it available.
DEPEND="
@@ -58,16 +58,15 @@ RDEPEND="
${DEPEND}
dev-python/pillow[${PYTHON_USEDEP}]
"
-# TODO: restore pythran optionality?
BDEPEND="
dev-lang/swig
>=dev-python/cython-0.29.18[${PYTHON_USEDEP}]
dev-python/pybind11[${PYTHON_USEDEP}]
- dev-python/pythran[${PYTHON_USEDEP}]
>=dev-util/meson-0.62.2
dev-util/patchelf
virtual/pkgconfig
doc? ( app-arch/unzip )
+ pythran? ( dev-python/pythran[${PYTHON_USEDEP}] )
test? ( dev-python/pytest-xdist[${PYTHON_USEDEP}] )"
PATCHES=(
@@ -84,11 +83,15 @@ distutils_enable_tests pytest
src_unpack() {
default
- if [[ ${PV} != *9999 ]] && use doc; then
+ if use doc; then
unzip -qo "${DISTDIR}"/${PN}-html-${DOC_PV}.zip -d html || die
fi
}
+src_configure() {
+ export SCIPY_USE_PYTHRAN=$(usex pythran 1 0)
+}
+
python_test() {
cd "${T}" || die
@@ -96,10 +99,9 @@ python_test() {
}
python_install_all() {
- if [[ ${PV} != *9999 ]] && use doc; then
- local DOCS=( "${DISTDIR}"/${PN}-ref-${DOC_PV}.pdf )
+ use doc && \
+ local DOCS=( "${DISTDIR}"/${PN}-ref-${DOC_PV}.pdf ) \
local HTML_DOCS=( "${WORKDIR}"/html/. )
- fi
distutils-r1_python_install_all
}