summaryrefslogtreecommitdiff
path: root/dev-python/scikit-learn/scikit-learn-1.3.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/scikit-learn/scikit-learn-1.3.2-r1.ebuild')
-rw-r--r--dev-python/scikit-learn/scikit-learn-1.3.2-r1.ebuild78
1 files changed, 0 insertions, 78 deletions
diff --git a/dev-python/scikit-learn/scikit-learn-1.3.2-r1.ebuild b/dev-python/scikit-learn/scikit-learn-1.3.2-r1.ebuild
deleted file mode 100644
index 1f42ebe8f21a..000000000000
--- a/dev-python/scikit-learn/scikit-learn-1.3.2-r1.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 2020-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Machine learning library for Python"
-HOMEPAGE="
- https://scikit-learn.org/stable/
- https://github.com/scikit-learn/scikit-learn/
- https://pypi.org/project/scikit-learn/
-"
-SRC_URI="
- https://github.com/scikit-learn/scikit-learn/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ppc64 ~riscv ~x86 ~arm64-macos ~x64-macos"
-IUSE="examples"
-
-DEPEND="
- virtual/blas:=
- virtual/cblas:=
-"
-RDEPEND="
- ${DEPEND}
- dev-python/wheel[${PYTHON_USEDEP}]
- >=dev-python/joblib-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.22.3[${PYTHON_USEDEP}]
- >=dev-python/scipy-1.5.0[${PYTHON_USEDEP}]
- >=dev-python/threadpoolctl-2.0.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/pythran-0.14.0[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
-"
-
-EPYTEST_XDIST=1
-distutils_enable_tests pytest
-
-# For some reason this wants to use urllib to fetch things from the internet
-# distutils_enable_sphinx doc \
-# dev-python/matplotlib \
-# dev-python/memory-profiler \
-# dev-python/numpydoc \
-# dev-python/pandas \
-# dev-python/pillow \
-# dev-python/seaborn \
-# dev-python/sphinx-gallery \
-# dev-python/sphinx-prompt \
-# dev-python/scikit-image
-
-python_test() {
- local EPYTEST_DESELECT=(
- # test broken with newer scipy, fixed upstream
- # https://github.com/scikit-learn/scikit-learn/issues/27578
- manifold/tests/test_locally_linear.py::test_singular_matrix
- # TODO
- gaussian_process/kernels.py::sklearn.gaussian_process.kernels.ExpSineSquared
- )
-
- rm -rf sklearn || die
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest --pyargs sklearn
-}
-
-python_install_all() {
- find "${S}" -name \*LICENSE.txt -delete || die
- distutils-r1_python_install_all
- use examples && dodoc -r examples
-}