summaryrefslogtreecommitdiff
path: root/dev-python/scikit-build-core
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/scikit-build-core')
-rw-r--r--dev-python/scikit-build-core/Manifest1
-rw-r--r--dev-python/scikit-build-core/scikit-build-core-0.6.0-r1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/scikit-build-core/Manifest b/dev-python/scikit-build-core/Manifest
index 412af3d664e2..a5f73811fbc7 100644
--- a/dev-python/scikit-build-core/Manifest
+++ b/dev-python/scikit-build-core/Manifest
@@ -1,5 +1,6 @@
DIST scikit_build_core-0.5.1.tar.gz 179718 BLAKE2B 31cd974a3deec188dc97ca708a04badfa8d75a0e66e85a2a814816bac126921aa5531f4f0de56f93a264b98edd341498298e1536502506d7b47ff40ca8bf92da SHA512 de7dd843a7979615a1421bc9ea6c0fde40b72ed94209783f176a5fb427a9fdee497a69e891441591d65d06a3ea619c4c67c9314cf0b7622d19cd88c149b43c7b
DIST scikit_build_core-0.6.0.tar.gz 189359 BLAKE2B 8c2a3028b34c6dff1daa33476d87b42c80762f0f6ec2bea4e5358e573330fb5b3f470ba9c79ba662126df3950779c1f4cd67eef51c571940baa396f47e7d5679 SHA512 11841ecc2035decdbb5538235f3d1ec75afc6611de2336d6ed5b762677988223723f58b18f4c6ffaa11c47e3bb2e28f3a0fb7c41d3e68a738b039add42f9729d
EBUILD scikit-build-core-0.5.1.ebuild 1380 BLAKE2B 28980d5c1055399af589595772ce6e12dc403f5370b49579d8fd10ec0ce65aed801f197fabe3bcc9ce4f37ad195018a1fb0d55b8ec0d0c12aad5fc6319136ef1 SHA512 16c41c6c578a243f0a650533d8a65455f02cdf65106abbc4c35f41a4a924fed0b5f603ea2de1da9440ddd6057d88f9312a4ab6458150e34ee0c7d45d40e120cd
+EBUILD scikit-build-core-0.6.0-r1.ebuild 1380 BLAKE2B db9b375b986a0370fe759f9fc650a2c638ddf2f5223c7a298d6b98abaa8ef8f5bdd879db378680605c79495d95493a54a5c8c4f373c25a58fbf9e9dc2d7ece6d SHA512 0b97118a897c18c8478b8fd48ee5ab166c830b22d779b9d8efca11d4e704c8cc7f0b331f2edc53bc4535f6717e3f50a0fb3742704ecaa0cbcb19a24beb1afdeb
EBUILD scikit-build-core-0.6.0.ebuild 1380 BLAKE2B 28980d5c1055399af589595772ce6e12dc403f5370b49579d8fd10ec0ce65aed801f197fabe3bcc9ce4f37ad195018a1fb0d55b8ec0d0c12aad5fc6319136ef1 SHA512 16c41c6c578a243f0a650533d8a65455f02cdf65106abbc4c35f41a4a924fed0b5f603ea2de1da9440ddd6057d88f9312a4ab6458150e34ee0c7d45d40e120cd
MISC metadata.xml 393 BLAKE2B 25bdc0bc295ed4bd7cd76a5a6952cb7fa5d5a404d3260562f2ed322d80f2466add0373a2a6b10a41c4dc2211e82e0a680735301d8844e70a54760301b4ab190f SHA512 176537f2027aedb3bc8bd16bbbcde8bfed246d621763e22a979f2942c016e1bafa5ef2d11d8d078e5d59970ea115864a8501185343bc3d4b9fd8493adbd16aab
diff --git a/dev-python/scikit-build-core/scikit-build-core-0.6.0-r1.ebuild b/dev-python/scikit-build-core/scikit-build-core-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..0e79f26c9258
--- /dev/null
+++ b/dev-python/scikit-build-core/scikit-build-core-0.6.0-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Build backend for CMake based projects"
+HOMEPAGE="
+ https://github.com/scikit-build/scikit-build-core/
+ https://pypi.org/project/scikit-build-core/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# we always want [pyproject] extra
+RDEPEND="
+ >=dev-python/packaging-20.9[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/pyproject-metadata-0.5[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/exceptiongroup[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.1[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ >=dev-python/cattrs-22.2.0[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ >=dev-python/pytest-subprocess-1.5[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO / we don't package validate_pyproject anyway
+ tests/test_schema.py::test_compare_schemas
+ )
+
+ epytest -m "not isolated and not network"
+}