summaryrefslogtreecommitdiff
path: root/dev-python/scikit-build-core
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/scikit-build-core')
-rw-r--r--dev-python/scikit-build-core/Manifest2
-rw-r--r--dev-python/scikit-build-core/scikit-build-core-0.9.1.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/scikit-build-core/Manifest b/dev-python/scikit-build-core/Manifest
index 87817079029d..8975f55e1e12 100644
--- a/dev-python/scikit-build-core/Manifest
+++ b/dev-python/scikit-build-core/Manifest
@@ -1,5 +1,7 @@
DIST scikit_build_core-0.8.2.tar.gz 203630 BLAKE2B 7093fd02891fe225ffee1b6da7800e49eb71c6468947fff1a80015eda8c9940f117196dfd067d0ea274d9958f8f13681ccd859f95ce9bf6a7d72eedc367489f3 SHA512 4b33936912806b5f607492d253d5cc6b2523d4892043caad82fed76140e53a0e9dec8178811a618cdc9b64f247e37145d474eb1979d181dd595b4905def1da8f
DIST scikit_build_core-0.9.0.tar.gz 224820 BLAKE2B 1221745656016ac90f1ac8bf9fb0d43c9f6f2dbd366b70522e2c8bcc15da87d64fc0ae84a583b811faa4cae638b9ab9d3987b21bccb29698fffb3d83cb26d881 SHA512 6d8dbb902a37c7d75f4e0c6d237f0aff6e6bcf08d0757bcef5d854b62b1ba3c562065aff7e87f0860803d4e768d0f6b2c4e866ae992b4fa510f0bee8d516431e
+DIST scikit_build_core-0.9.1.tar.gz 224992 BLAKE2B aaa02572c278138ba2463e42e4514647f9617cb257cdcb6f86a9a97e332967a867a2da97c2407388eae566a998496f6e712781d6e8af960a9fde4e8771baf41f SHA512 8e4632694f862db1fcc05d3c5844fee601ea975f2f3fd548d214d12bfb19e8f200aed199ed04142c37b3454e0ba077e658d85d976ceba875f2642f2d13a3f8c2
EBUILD scikit-build-core-0.8.2.ebuild 1550 BLAKE2B b49b44b6ef81fcf3bf4bed084a2aa7dcf1ef573388bd12c6c21263272bb52a6a2e62058f393fc2c6487905c720a043a455c447eaefc413668e6b8bce823bdfed SHA512 dbc9bdacbbd267e7ff09dd493ab4c194c95c13516f44d85a32b3c73f3ebbf358005b07c64eaaecb5b49784a86a6f1a7ac61e25b1d8fcfcc5cfdf03792ac27615
EBUILD scikit-build-core-0.9.0.ebuild 1685 BLAKE2B 5cefa7c0ac23ac8b7d14b50710bf71326a1abee1620bf134150966b623302d8ee45e8a953e75381e1d6f533f73ed40fcd6eb47511d34c0a2290c1fc4955aaa89 SHA512 1108a8fbc3a5888d523795292f73b24b50e608bf3717692dbef78e0a72c57110a4823e2d1533258a458ade02367baa2e86ab77fedb21ae004a2fbe301aebfd0a
+EBUILD scikit-build-core-0.9.1.ebuild 1685 BLAKE2B 5cefa7c0ac23ac8b7d14b50710bf71326a1abee1620bf134150966b623302d8ee45e8a953e75381e1d6f533f73ed40fcd6eb47511d34c0a2290c1fc4955aaa89 SHA512 1108a8fbc3a5888d523795292f73b24b50e608bf3717692dbef78e0a72c57110a4823e2d1533258a458ade02367baa2e86ab77fedb21ae004a2fbe301aebfd0a
MISC metadata.xml 393 BLAKE2B 25bdc0bc295ed4bd7cd76a5a6952cb7fa5d5a404d3260562f2ed322d80f2466add0373a2a6b10a41c4dc2211e82e0a680735301d8844e70a54760301b4ab190f SHA512 176537f2027aedb3bc8bd16bbbcde8bfed246d621763e22a979f2942c016e1bafa5ef2d11d8d078e5d59970ea115864a8501185343bc3d4b9fd8493adbd16aab
diff --git a/dev-python/scikit-build-core/scikit-build-core-0.9.1.ebuild b/dev-python/scikit-build-core/scikit-build-core-0.9.1.ebuild
new file mode 100644
index 000000000000..35a8eee75dc0
--- /dev/null
+++ b/dev-python/scikit-build-core/scikit-build-core-0.9.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Build backend for CMake based projects"
+HOMEPAGE="
+ https://github.com/scikit-build/scikit-build-core/
+ https://pypi.org/project/scikit-build-core/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# we always want [pyproject] extra
+RDEPEND="
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/pyproject-metadata-0.5[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/exceptiongroup[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.2.2[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ >=dev-python/cattrs-22.2.0[${PYTHON_USEDEP}]
+ dev-python/fastjsonschema[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ >=dev-python/pytest-subprocess-1.5[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local _EPYTEST_DESELECT=(
+ # TODO / we don't package validate_pyproject anyway
+ tests/test_schema.py::test_compare_schemas
+ # setuptools now respects PEP 625
+ tests/test_setuptools_pep517.py::test_pep517_sdist
+ )
+ local EPYTEST_IGNORE=(
+ # needs unpackaged validate_pyproject
+ tests/test_schema.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p subprocess -m "not isolated and not network"
+}