summaryrefslogtreecommitdiff
path: root/dev-python/schema
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/schema')
-rw-r--r--dev-python/schema/Manifest3
-rw-r--r--dev-python/schema/metadata.xml12
-rw-r--r--dev-python/schema/schema-0.7.5-r1.ebuild27
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/schema/Manifest b/dev-python/schema/Manifest
new file mode 100644
index 000000000000..2ec970bd0683
--- /dev/null
+++ b/dev-python/schema/Manifest
@@ -0,0 +1,3 @@
+DIST schema-0.7.5.tar.gz 48173 BLAKE2B 3d112ee1960c79a64ec2980cbd70403b6dbcafdeeb4f5826c427426aafd602691fd5ceab408edf88e50854a7d66306a73a4729c056a1ca7d1eaa4d0c725901a9 SHA512 10184a4d2a30600d5c6fe9fcde33925137825e811af691c40fee841f88e4a5106ef7e79be2a0ddddd0e0b74892bf889c3d2eff934a36dbca269cd7bf22748d39
+EBUILD schema-0.7.5-r1.ebuild 499 BLAKE2B 812a132c5b75acd3aeb84cac694c860267981ad19aa3ca61afc141828e54322cf5cbd5dd5427fb4b2f3aabf04889c78ffff3c15d260c97f7dd4a41ef12219eaf SHA512 37a4d2f92c6334aeb3b91b5287abec2553eaa5a7f2958179ed427defc552e17ab7f1a8ba97c310dfdb254d9a6a8ba5019edd36df230dd01420ded23951237789
+MISC metadata.xml 367 BLAKE2B 99fe68b6e2257a73945d542deb976de50a83e194d7666b847406569433cfa11650854e07e79f7e3a4ff38aa9869b279b02b45933f598e16fc8feb864b402929b SHA512 5b81fd9ad041c68a7cb0672b937fa4dc8b4fee20f1fba6e53a884c0f31b9c69fad38b0795b6397de9fa3e32081cf9fc5492dcc00cfb6b0da70db6b213dcde093
diff --git a/dev-python/schema/metadata.xml b/dev-python/schema/metadata.xml
new file mode 100644
index 000000000000..44897a815387
--- /dev/null
+++ b/dev-python/schema/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">keleshev/schema</remote-id>
+ <remote-id type="pypi">schema</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/schema/schema-0.7.5-r1.ebuild b/dev-python/schema/schema-0.7.5-r1.ebuild
new file mode 100644
index 000000000000..8c9f00ff5075
--- /dev/null
+++ b/dev-python/schema/schema-0.7.5-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simple data validation library"
+HOMEPAGE="
+ https://github.com/keleshev/schema/
+ https://pypi.org/project/schema/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # py2 leftover
+ > requirements.txt || die
+ distutils-r1_src_prepare
+}