summaryrefslogtreecommitdiff
path: root/dev-python/schedule/schedule-0.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/schedule/schedule-0.5.0.ebuild')
-rw-r--r--dev-python/schedule/schedule-0.5.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/schedule/schedule-0.5.0.ebuild b/dev-python/schedule/schedule-0.5.0.ebuild
new file mode 100644
index 000000000000..c75611808a47
--- /dev/null
+++ b/dev-python/schedule/schedule-0.5.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python{3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Python job scheduling for humans"
+HOMEPAGE="https://github.com/dbader/schedule"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/mock-2.0.0
+ >=dev-python/pytest-3.0.3 )"
+
+python_test() {
+ py.test test_schedule.py || die
+}