summaryrefslogtreecommitdiff
path: root/dev-python/rustworkx
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rustworkx')
-rw-r--r--dev-python/rustworkx/Manifest1
-rw-r--r--dev-python/rustworkx/rustworkx-0.15.1-r1.ebuild164
2 files changed, 165 insertions, 0 deletions
diff --git a/dev-python/rustworkx/Manifest b/dev-python/rustworkx/Manifest
index 529599dabf67..92e89be5be10 100644
--- a/dev-python/rustworkx/Manifest
+++ b/dev-python/rustworkx/Manifest
@@ -153,5 +153,6 @@ DIST zerocopy-derive-0.7.32.crate 37623 BLAKE2B 8b583d39d7bf9c3dbbba578120751c66
DIST zerocopy-derive-0.7.34.crate 37907 BLAKE2B 23a698c3c892187307007cbc76c9338dbe163e4f14d4ea73969ba834f5c6732d16f5bc26e2e85c5e3df2100b28e6e72ae6473b2159f5160ee19befdef3615f98 SHA512 1bd93062b0d2c699066f8a991326b4470426aae0517d33748a8f0e52b009fc46e6b0b238abe97462a2e13c870fa3d0d070615870e6dbbf8b6991c0e3fb5c3e63
EBUILD rustworkx-0.14.2-r1.ebuild 3289 BLAKE2B 6963861ae52f71fa6ddec20e22dfc680ec5386f449bbc14a026b5b3e7d989e5739e1096452034d705d7785f5d85ab36df61c32c69c0593a3810cb9ea4632c5f5 SHA512 b730cd6ff7d7353fcc1189cb30dc3e94e2913b914d49b912287fc465f8c6d6deaf70355f5572ab19b55eb6f59fe960f819102c0c18ca33ca9d0f8538cb238620
EBUILD rustworkx-0.15.0.ebuild 3163 BLAKE2B b18e7fca5e9ff2e7a35dee71d11700eeb92151d74693696745eab2a03d23719dc306bae92f11733b99f4b7fe8a38f76df2d867b01f010db4e4be6e62324b5b35 SHA512 a0117dc3669ff18a0e10599452739ea8b09f9b96e491a6be32cd5c0df1a76047ec632103eb9eafe433e8fc360fa550c661857baa7d150120a5885b18f0423fac
+EBUILD rustworkx-0.15.1-r1.ebuild 3435 BLAKE2B d45f9b785b7922f086c7a8ace878341ab021d7b7cf770b91cff95cadfa3bc36a7519d61c205ec09f150c7fe0e7c36f1721c29014a144f3121706f0354ff18015 SHA512 05aa9bebf3ee2dca95fe5cf92e6084d41fdddfad1fd1db6624c88c920b6ba063397de797d6a6ee35491b10344eeb32de3ba9691ef026ce01d3168a68be4793d0
EBUILD rustworkx-0.15.1.ebuild 3193 BLAKE2B 4ac62f856fa60e74717598ca40129c3a9d9ccae9c61b9f6fc5a713e9b5f2082dc3863011a76da5e959809ac353d52016380dc261115bff6ca79bf2829c6fd922 SHA512 23e45a3ccc7e0be527599d14299cbb92ee109096d65c00414805065f28de98cb7d67c524c7c69f160e982c0821737971f190034b2a36a1d2971be068c3f7e02d
MISC metadata.xml 1286 BLAKE2B 8f121e669008927c921d7425b45ee5f103eaa6fdfdeafa9e6f96de67cad37bd28894411b68f25b8928b043774f17629b855beb4228aa4f1461394089b67510a9 SHA512 b95fe484c2e21621003f1ee70636b75eda8f941f94cb5549750cfb9234067c1e79d5dc9c85b08c8965578360fcb85d6cf726c3787cc66e3d56c0f0f9e45ac867
diff --git a/dev-python/rustworkx/rustworkx-0.15.1-r1.ebuild b/dev-python/rustworkx/rustworkx-0.15.1-r1.ebuild
new file mode 100644
index 000000000000..7cc5dad7a8b2
--- /dev/null
+++ b/dev-python/rustworkx/rustworkx-0.15.1-r1.ebuild
@@ -0,0 +1,164 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+CRATES="
+ ahash@0.8.11
+ alga@0.9.3
+ allocator-api2@0.2.18
+ approx@0.3.2
+ autocfg@1.3.0
+ bitflags@2.6.0
+ cfg-if@1.0.0
+ crossbeam-deque@0.8.5
+ crossbeam-epoch@0.9.18
+ crossbeam-utils@0.8.20
+ either@1.13.0
+ equivalent@1.0.1
+ fixedbitset@0.4.2
+ getrandom@0.2.15
+ hashbrown@0.12.3
+ hashbrown@0.14.5
+ heck@0.4.1
+ hermit-abi@0.3.9
+ indexmap@1.9.3
+ indexmap@2.2.6
+ indoc@2.0.5
+ itertools@0.10.5
+ itertools@0.11.0
+ itoa@1.0.11
+ libc@0.2.155
+ libm@0.2.8
+ lock_api@0.4.12
+ matrixmultiply@0.3.8
+ memchr@2.7.4
+ memoffset@0.9.1
+ ndarray-stats@0.5.1
+ ndarray@0.15.6
+ noisy_float@0.2.0
+ num-bigint@0.4.6
+ num-complex@0.2.4
+ num-complex@0.4.6
+ num-integer@0.1.46
+ num-traits@0.2.19
+ num_cpus@1.16.0
+ numpy@0.21.0
+ once_cell@1.19.0
+ parking_lot@0.12.3
+ parking_lot_core@0.9.10
+ petgraph@0.6.5
+ portable-atomic@1.6.0
+ ppv-lite86@0.2.17
+ priority-queue@2.0.3
+ proc-macro2@1.0.86
+ pyo3-build-config@0.21.2
+ pyo3-ffi@0.21.2
+ pyo3-macros-backend@0.21.2
+ pyo3-macros@0.21.2
+ pyo3@0.21.2
+ quick-xml@0.34.0
+ quote@1.0.36
+ rand@0.8.5
+ rand_chacha@0.3.1
+ rand_core@0.6.4
+ rand_pcg@0.3.1
+ rawpointer@0.2.1
+ rayon-cond@0.3.0
+ rayon-core@1.12.1
+ rayon@1.10.0
+ redox_syscall@0.5.2
+ rustc-hash@1.1.0
+ ryu@1.0.18
+ scopeguard@1.2.0
+ serde@1.0.203
+ serde_derive@1.0.203
+ serde_json@1.0.118
+ smallvec@1.13.2
+ sprs@0.11.1
+ syn@2.0.68
+ target-lexicon@0.12.14
+ unicode-ident@1.0.12
+ unindent@0.2.3
+ version_check@0.9.4
+ wasi@0.11.0+wasi-snapshot-preview1
+ windows-targets@0.52.5
+ windows_aarch64_gnullvm@0.52.5
+ windows_aarch64_msvc@0.52.5
+ windows_i686_gnu@0.52.5
+ windows_i686_gnullvm@0.52.5
+ windows_i686_msvc@0.52.5
+ windows_x86_64_gnu@0.52.5
+ windows_x86_64_gnullvm@0.52.5
+ windows_x86_64_msvc@0.52.5
+ zerocopy-derive@0.7.34
+ zerocopy@0.7.34
+"
+
+inherit cargo distutils-r1
+
+DESCRIPTION="A high performance Python graph library implemented in Rust"
+HOMEPAGE="
+ https://github.com/Qiskit/rustworkx/
+ https://pypi.org/project/rustworkx/
+"
+SRC_URI="
+ https://github.com/Qiskit/rustworkx/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ ${CARGO_CRATE_URIS}
+"
+
+LICENSE="Apache-2.0"
+# Dependent crate licenses
+LICENSE+="
+ Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD-2 MIT
+ Unicode-DFS-2016
+ || ( LGPL-3+ MPL-2.0 )
+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/numpy-1.16.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-rust[${PYTHON_USEDEP}]
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/graphviz[${PYTHON_USEDEP}]
+ >=dev-python/networkx-2.5[${PYTHON_USEDEP}]
+ dev-python/stestr[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.5.0[${PYTHON_USEDEP}]
+ media-gfx/graphviz[gts]
+ )
+"
+
+# Libraries built with rust do not use CFLAGS and LDFLAGS.
+QA_FLAGS_IGNORED="usr/lib.*/py.*/site-packages/rustworkx/rustworkx.*\\.so"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # force unstable ABI to workaround stable ABI crash in py3.13
+ # https://github.com/PyO3/pyo3/issues/4311
+ sed -i -e 's:"abi3-py38",::' Cargo.toml || die
+ export UNSAFE_PYO3_SKIP_VERSION_CHECK=1
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local EPYTEST_DESELECT=(
+ # TODO: hangs
+ tests/retworkx_backwards_compat/visualization/test_mpl.py
+ tests/rustworkx_tests/visualization/test_mpl.py
+ )
+ rm -rf rustworkx || die
+ epytest
+}