summaryrefslogtreecommitdiff
path: root/dev-python/ruledispatch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ruledispatch')
-rw-r--r--dev-python/ruledispatch/Manifest4
-rw-r--r--dev-python/ruledispatch/files/ruledispatch_as_syntax_fix.patch49
-rw-r--r--dev-python/ruledispatch/metadata.xml8
-rw-r--r--dev-python/ruledispatch/ruledispatch-0.5_pre2306-r2.ebuild45
4 files changed, 106 insertions, 0 deletions
diff --git a/dev-python/ruledispatch/Manifest b/dev-python/ruledispatch/Manifest
new file mode 100644
index 000000000000..bd5a5bc8f0fa
--- /dev/null
+++ b/dev-python/ruledispatch/Manifest
@@ -0,0 +1,4 @@
+AUX ruledispatch_as_syntax_fix.patch 1650 BLAKE2B 00d2f5879bb602b24a2632b4fe02a2b72dff7f214e2e8092161cdd371ecd01b230cf1c88f26ab6db11a825e09cf4eef9d8468492119c54b51636c7c54d7e3bda SHA512 c8ba8d570f82975195be4478c8309c62372ec1f3693bfa9b1fb5a208a56f0984c62d0f2ad9f27751197f144acf9795d1cc0d1b599bcd494a3ffe017aa9fdd89c
+DIST RuleDispatch-0.5a0.dev-r2306.tar.gz 186405 BLAKE2B aad8d7546ff7b26506b39e60e073aeab9f70df96dc2f41a80bee0dba100ab64376a231671168e77eb36b3e731854061699c5678085189bca416d3da9ce4e0484 SHA512 5ee5f22b6ba755e79c108925d321ade10c6a2e06c309e753650385d2dfbeb2830eaeccee6b71338ec38598c877625b95acf21b6059faf91e9f6119e533b133b1
+EBUILD ruledispatch-0.5_pre2306-r2.ebuild 1333 BLAKE2B 680c01b3464ecdac46d069a3c9cf980370089a2c49925600b3296662d1098a8ba805975e164c6369f0ceb466e36491449d358ca63ceb57e9725693b4b98580ac SHA512 0205352079acbcae91822cb2f523aaf8f9de483f8fe1d9d87eac87f47a531e5c2c01622263f3ad4bf37008fcdaefa2f966759b851c24e30f1dbf9b9729042005
+MISC metadata.xml 236 BLAKE2B 167eb58da19caba0e03167e2f209e118ce8a468851bca2790a0353112848fffcd72522497e5f951bf5c6eafa9691fa2a1ad980843cb4170a8194f3b8178ebe16 SHA512 0f2c2a0401b53543eac90eafdd4d11c5913be07f47b968e2892ca92c265adbd9564f02a491ff2607d7031194ba3e50c7720851537341b1541120821c487147a3
diff --git a/dev-python/ruledispatch/files/ruledispatch_as_syntax_fix.patch b/dev-python/ruledispatch/files/ruledispatch_as_syntax_fix.patch
new file mode 100644
index 000000000000..47960b3c23f5
--- /dev/null
+++ b/dev-python/ruledispatch/files/ruledispatch_as_syntax_fix.patch
@@ -0,0 +1,49 @@
+Added by: Jesus Rivero (Neurogeek)
+On: 25 Jul 2009
+Per Upstream bug: https://bugs.launchpad.net/ubuntu/+source/ruledispatch/+bug/342916
+
+diff -uNr RuleDispatch.orig/src/dispatch/__init__.py RuleDispatch/src/dispatch/__init__.py
+--- RuleDispatch.orig/src/dispatch/__init__.py 2009-07-25 13:25:08.000000000 +0000
++++ RuleDispatch/src/dispatch/__init__.py 2009-07-25 13:27:19.000000000 +0000
+@@ -95,7 +95,7 @@
+ return decorate_assignment(callback)
+
+
+-def as(*decorators):
++def as_(*decorators):
+ """Use Python 2.4 decorators w/Python 2.2+
+
+ Example:
+Files RuleDispatch.orig/src/dispatch/__init__.pyc and RuleDispatch/src/dispatch/__init__.pyc differ
+Files RuleDispatch.orig/src/dispatch/interfaces.pyc and RuleDispatch/src/dispatch/interfaces.pyc differ
+diff -uNr RuleDispatch.orig/src/dispatch/predicates.py RuleDispatch/src/dispatch/predicates.py
+--- RuleDispatch.orig/src/dispatch/predicates.py 2009-07-25 13:25:08.000000000 +0000
++++ RuleDispatch/src/dispatch/predicates.py 2009-07-25 13:27:58.000000000 +0000
+@@ -236,7 +236,7 @@
+
+ return or_, (EXPR_GETTER_ID,)
+
+- [as(classmethod)]
++ [as_(classmethod)]
+ def immediate(klass,seq):
+ for item in seq:
+ if item:
+@@ -260,7 +260,7 @@
+
+ return and_, (EXPR_GETTER_ID,)
+
+- [as(classmethod)]
++ [as_(classmethod)]
+ def immediate(klass,seq):
+ for item in seq:
+ if not item:
+@@ -278,7 +278,7 @@
+ return get(argIds[2])
+ return ifelse, (EXPR_GETTER_ID,)
+
+- [as(classmethod)]
++ [as_(classmethod)]
+ def immediate(klass,seq):
+ if seq[1]: return seq[0]
+ return seq[2]
+
diff --git a/dev-python/ruledispatch/metadata.xml b/dev-python/ruledispatch/metadata.xml
new file mode 100644
index 000000000000..9e5274c5b4ae
--- /dev/null
+++ b/dev-python/ruledispatch/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-python/ruledispatch/ruledispatch-0.5_pre2306-r2.ebuild b/dev-python/ruledispatch/ruledispatch-0.5_pre2306-r2.ebuild
new file mode 100644
index 000000000000..1c538b5e6057
--- /dev/null
+++ b/dev-python/ruledispatch/ruledispatch-0.5_pre2306-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils versionator flag-o-matic
+
+MY_PN="RuleDispatch"
+MY_P="${MY_PN}-$(get_version_component_range 1-2)a0.dev-$(get_version_component_range 3-)"
+MY_P="${MY_P/pre/r}"
+
+DESCRIPTION="Rule-based Dispatching and Generic Functions"
+HOMEPAGE="http://peak.telecommunity.com/"
+# http://svn.eby-sarna.com/RuleDispatch/
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+
+LICENSE="|| ( PSF-2.4 ZPL )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=">=dev-python/pyprotocols-1.0_pre2306[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_PN}"
+
+PATCHES=( "${FILESDIR}/${PN}_as_syntax_fix.patch" )
+
+python_configure_all() {
+ append-flags -fno-strict-aliasing
+}
+
+python_test() {
+ cd "${BUILD_DIR}/lib" || die
+ # parallel build makes a salad; einfo msg lets us see what's occuring
+ for test in dispatch/tests/test_*.py; do
+ "${PYTHON}" $test && einfo "Tests $test passed under ${EPYTHON}" \
+ || die "Tests failed under ${EPYTHON}"
+ done
+ # doctest appears old and unmaintained, left for just in case
+ # "${PYTHON}" dispatch/tests/doctest.py
+ einfo "Tests passed under ${EPYTHON}"
+}