summaryrefslogtreecommitdiff
path: root/dev-python/rtslib-fb/rtslib-fb-2.1.69.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rtslib-fb/rtslib-fb-2.1.69.ebuild')
-rw-r--r--dev-python/rtslib-fb/rtslib-fb-2.1.69.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/rtslib-fb/rtslib-fb-2.1.69.ebuild b/dev-python/rtslib-fb/rtslib-fb-2.1.69.ebuild
new file mode 100644
index 000000000000..20246ee07505
--- /dev/null
+++ b/dev-python/rtslib-fb/rtslib-fb-2.1.69.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1 systemd
+
+DESCRIPTION="A Python object API for managing the Linux LIO kernel target"
+HOMEPAGE="https://github.com/open-iscsi/rtslib-fb"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/pyudev[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit "${FILESDIR}/target.service"
+}