summaryrefslogtreecommitdiff
path: root/dev-python/rtslib-fb/rtslib-fb-2.1.66.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rtslib-fb/rtslib-fb-2.1.66.ebuild')
-rw-r--r--dev-python/rtslib-fb/rtslib-fb-2.1.66.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/rtslib-fb/rtslib-fb-2.1.66.ebuild b/dev-python/rtslib-fb/rtslib-fb-2.1.66.ebuild
new file mode 100644
index 000000000000..63d56223ca51
--- /dev/null
+++ b/dev-python/rtslib-fb/rtslib-fb-2.1.66.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python object API for managing the Linux LIO kernel target"
+HOMEPAGE="https://github.com/open-iscsi/rtslib-fb"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/pyudev[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ !dev-python/rtslib"