summaryrefslogtreecommitdiff
path: root/dev-python/rply/rply-0.7.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rply/rply-0.7.7.ebuild')
-rw-r--r--dev-python/rply/rply-0.7.7.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/rply/rply-0.7.7.ebuild b/dev-python/rply/rply-0.7.7.ebuild
new file mode 100644
index 000000000000..cb3fca642b26
--- /dev/null
+++ b/dev-python/rply/rply-0.7.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python parser generator that also works with RPython"
+HOMEPAGE="https://github.com/alex/rply"
+SRC_URI="https://github.com/alex/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}