summaryrefslogtreecommitdiff
path: root/dev-python/rospkg/rospkg-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rospkg/rospkg-9999.ebuild')
-rw-r--r--dev-python/rospkg/rospkg-9999.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/rospkg/rospkg-9999.ebuild b/dev-python/rospkg/rospkg-9999.ebuild
index 3dd32f0afe6f..9fe2198838eb 100644
--- a/dev-python/rospkg/rospkg-9999.ebuild
+++ b/dev-python/rospkg/rospkg-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -13,7 +13,7 @@ fi
inherit ${SCM} distutils-r1
DESCRIPTION="Standalone Python library for the ROS package system"
-HOMEPAGE="http://wiki.ros.org/rospkg"
+HOMEPAGE="https://wiki.ros.org/rospkg"
if [ "${PV#9999}" != "${PV}" ] ; then
SRC_URI=""
KEYWORDS=""
@@ -31,7 +31,9 @@ IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+"
BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (