summaryrefslogtreecommitdiff
path: root/dev-python/ropemode/ropemode-0.6.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ropemode/ropemode-0.6.1.ebuild')
-rw-r--r--dev-python/ropemode/ropemode-0.6.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/ropemode/ropemode-0.6.1.ebuild b/dev-python/ropemode/ropemode-0.6.1.ebuild
new file mode 100644
index 000000000000..e43b13d2d502
--- /dev/null
+++ b/dev-python/ropemode/ropemode-0.6.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A helper for using rope refactoring library in IDEs"
+HOMEPAGE="
+ https://github.com/python-rope/ropemode/
+ https://pypi.org/project/ropemode/
+"
+SRC_URI="
+ https://github.com/python-rope/ropemode/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/rope[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest