summaryrefslogtreecommitdiff
path: root/dev-python/rope/rope-1.12.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rope/rope-1.12.0.ebuild')
-rw-r--r--dev-python/rope/rope-1.12.0.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/rope/rope-1.12.0.ebuild b/dev-python/rope/rope-1.12.0.ebuild
deleted file mode 100644
index 7041b9fbec49..000000000000
--- a/dev-python/rope/rope-1.12.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python refactoring library"
-HOMEPAGE="
- https://pypi.org/project/rope/
- https://github.com/python-rope/rope/
-"
-
-LICENSE="LGPL-3+"
-SLOT="0"
-KEYWORDS="amd64 arm64 ~ppc64 x86"
-IUSE="doc"
-
-RDEPEND="
- >=dev-python/pytoolconfig-1.2.2[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/build[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # our venv style confuses this comparison
- ropetest/contrib/autoimport/utilstest.py::test_get_package_source_typing
- ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_typing
- ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_compiled
-)