summaryrefslogtreecommitdiff
path: root/dev-python/roman/roman-4.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/roman/roman-4.2.ebuild')
-rw-r--r--dev-python/roman/roman-4.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/roman/roman-4.2.ebuild b/dev-python/roman/roman-4.2.ebuild
new file mode 100644
index 000000000000..d9b08af45690
--- /dev/null
+++ b/dev-python/roman/roman-4.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="An Integer to Roman numerals converter"
+HOMEPAGE="
+ https://pypi.org/project/roman/
+ https://github.com/zopefoundation/roman
+"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ mv "${S}/src/tests.py" . || die "moving test file failed"
+ distutils-r1_python_prepare_all
+}