summaryrefslogtreecommitdiff
path: root/dev-python/rfc3987/rfc3987-1.3.8-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rfc3987/rfc3987-1.3.8-r2.ebuild')
-rw-r--r--dev-python/rfc3987/rfc3987-1.3.8-r2.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/rfc3987/rfc3987-1.3.8-r2.ebuild b/dev-python/rfc3987/rfc3987-1.3.8-r2.ebuild
index 59f2ba52b4ff..e8a27e88d645 100644
--- a/dev-python/rfc3987/rfc3987-1.3.8-r2.ebuild
+++ b/dev-python/rfc3987/rfc3987-1.3.8-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -18,8 +18,12 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+# dev-python/regex doesn't support pypy. The package falls back to re and has most
+# functionality without it.
RDEPEND="
- dev-python/regex[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/regex[${PYTHON_USEDEP}]
+ ' 'python*')
"
BDEPEND="
${RDEPEND}