summaryrefslogtreecommitdiff
path: root/dev-python/rfc3986
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rfc3986')
-rw-r--r--dev-python/rfc3986/Manifest7
-rw-r--r--dev-python/rfc3986/metadata.xml19
-rw-r--r--dev-python/rfc3986/rfc3986-0.3.1.ebuild29
-rw-r--r--dev-python/rfc3986/rfc3986-0.4.1.ebuild29
-rw-r--r--dev-python/rfc3986/rfc3986-1.1.0.ebuild29
5 files changed, 113 insertions, 0 deletions
diff --git a/dev-python/rfc3986/Manifest b/dev-python/rfc3986/Manifest
new file mode 100644
index 000000000000..5137e04b860e
--- /dev/null
+++ b/dev-python/rfc3986/Manifest
@@ -0,0 +1,7 @@
+DIST rfc3986-0.3.1.tar.gz 21591 BLAKE2B b24500baf27e4f17d22dbeb839262edb11b1c8c54ddd29782c2f4d83b5322e30f8800122349c9da0787f07c94e212616bbaace3b1d3bb1b2a5205aeba55355b3 SHA512 47c0cff5b67de5cc54ce3a24eb6d192a8b1414f5bb25e54056561fc0394058ec94853e62b9495dd72e15074921b66153279d4dffd1c199e252d569646a34aaed
+DIST rfc3986-0.4.1.tar.gz 22354 BLAKE2B db2a7edefa89fd3780721904c5e1b623d34dea5e8913c606336771d22f03c258f0a3cd3b71f42db6a6f2065bb055cf6938c10f166730953fe78cdc50dd0f148a SHA512 a4731206a4179d3970fcf9c21405f7e9686268ef3610ab5ca2413a867d83b83188c0efd5958b0b4ba8fc4076da9bc0cf18aef774213a1b58fc42bfc8a6d5dd92
+DIST rfc3986-1.1.0.tar.gz 39381 BLAKE2B cb890ae46c1428ddca1aed4a49660e2620659e7af64dbdb22c2514323ede374c28bbbd8401a5b4db257ba47e617ad7e8ae486f751fd4a7580808c68ff289ec13 SHA512 5e43ca7df586011900d2f01edfb20388598f77218e5a63904557bec0f1d0cb0a35f4980014de9c943ecc43a5a7ab3f7b815fbcfc9318e494c24a14fed2d1fac6
+EBUILD rfc3986-0.3.1.ebuild 691 BLAKE2B 8a16ab5c1b02a0936b3575de56cf9eec9f042886a7b436c6869a8ba621f4948d184b8ce2d61e861893e3397326f0b62567aac122571d30d02cfc6e63edadd321 SHA512 f8e7eab867f5dc53c636c86f71716a8ab34b4a80caab292d170ac7f022bc6352a611311e299415e6f07483d869c88fb66ddd6313b28605677d5cbd67ce9cea50
+EBUILD rfc3986-0.4.1.ebuild 695 BLAKE2B 47703d2f0ce1f12c65ab92849d204276352069fd180e00ff7d8e98091eb8cad0b780af7ea6ee24768104773e71020e97845b53ecaa3397c4f235ec956fb26c95 SHA512 48fce5247a98bc8531007e16b2fa882eed7bed53328e6f2d191ad1f36b1249f7442ec752596587133a91e6c19156a466671ba5311ef9785e9318b26c8c6d1dd6
+EBUILD rfc3986-1.1.0.ebuild 691 BLAKE2B 454fec2ba95ec14cabbe7aacde784477733ce3fb964fe35faea6b8839bc5be93324dd6a83fbfadb40e1410b03eab0ab2674d09af264f5b1db5c2ad761deaee59 SHA512 b1dba414a5a78acb41bbc4a7d61f55b5f55e01e4ab9d1207cb67fe0afe4a75dbc819f47ae28d772fdb10ae424bf2abe8acb4ce9c5d22667b061009445c97e468
+MISC metadata.xml 601 BLAKE2B 0cd1efd0eab6850689b22d3012463b24fe77156d81ab4cef046f2bedf7c8d1bc9b82707bb8e493243fe6d1b0958f8e7936f749c1e90a66c3b7052d13d7655b4d SHA512 2a535235ea1111e30083c9e7799fa584e624aa39fbbb715b49aefb0ddb8b96135da1533f8bad3e4190b6eada990da906f1bbba66fa9b5a29baf4963161c52426
diff --git a/dev-python/rfc3986/metadata.xml b/dev-python/rfc3986/metadata.xml
new file mode 100644
index 000000000000..6bf17e96bd2c
--- /dev/null
+++ b/dev-python/rfc3986/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>openstack@gentoo.org</email>
+ <name>Openstack</name>
+ </maintainer>
+ <longdescription lang="en">
+ Validating URI References per RFC 3986
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">rfc3986</remote-id>
+ <remote-id type="github">sigmavirus24/rfc3986</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/rfc3986/rfc3986-0.3.1.ebuild b/dev-python/rfc3986/rfc3986-0.3.1.ebuild
new file mode 100644
index 000000000000..878d5d608233
--- /dev/null
+++ b/dev-python/rfc3986/rfc3986-0.3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3)
+
+inherit distutils-r1
+
+DESCRIPTION="Validating URI References per RFC 3986"
+HOMEPAGE="https://tools.ietf.org/html/rfc3986
+ https://github.com/sigmavirus24/rfc3986
+ https://rfc3986.rtfd.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND=""
+
+python_test() {
+ py.test -vv || die
+}
diff --git a/dev-python/rfc3986/rfc3986-0.4.1.ebuild b/dev-python/rfc3986/rfc3986-0.4.1.ebuild
new file mode 100644
index 000000000000..0b0b08a2442b
--- /dev/null
+++ b/dev-python/rfc3986/rfc3986-0.4.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3)
+
+inherit distutils-r1
+
+DESCRIPTION="Validating URI References per RFC 3986"
+HOMEPAGE="https://tools.ietf.org/html/rfc3986
+ https://github.com/sigmavirus24/rfc3986
+ https://rfc3986.rtfd.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ~arm64 ~hppa ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh sparc x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND=""
+
+python_test() {
+ py.test -vv || die
+}
diff --git a/dev-python/rfc3986/rfc3986-1.1.0.ebuild b/dev-python/rfc3986/rfc3986-1.1.0.ebuild
new file mode 100644
index 000000000000..636645481adb
--- /dev/null
+++ b/dev-python/rfc3986/rfc3986-1.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3)
+
+inherit distutils-r1
+
+DESCRIPTION="Validating URI References per RFC 3986"
+HOMEPAGE="https://tools.ietf.org/html/rfc3986
+ https://github.com/sigmavirus24/rfc3986
+ https://rfc3986.rtfd.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND=""
+
+python_test() {
+ py.test -vv || die
+}