summaryrefslogtreecommitdiff
path: root/dev-python/rfc3986/rfc3986-1.3.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rfc3986/rfc3986-1.3.2.ebuild')
-rw-r--r--dev-python/rfc3986/rfc3986-1.3.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/rfc3986/rfc3986-1.3.2.ebuild b/dev-python/rfc3986/rfc3986-1.3.2.ebuild
new file mode 100644
index 000000000000..bd688f4924c2
--- /dev/null
+++ b/dev-python/rfc3986/rfc3986-1.3.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3)
+
+inherit distutils-r1
+
+DESCRIPTION="Validating URI References per RFC 3986"
+HOMEPAGE="https://tools.ietf.org/html/rfc3986
+ https://github.com/python-hyper/rfc3986
+ https://rfc3986.rtfd.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="idna test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ idna? ( dev-python/idna[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND=""
+
+python_test() {
+ py.test -vv || die
+}