summaryrefslogtreecommitdiff
path: root/dev-python/rfc3339-validator/rfc3339-validator-0.1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rfc3339-validator/rfc3339-validator-0.1.2.ebuild')
-rw-r--r--dev-python/rfc3339-validator/rfc3339-validator-0.1.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/rfc3339-validator/rfc3339-validator-0.1.2.ebuild b/dev-python/rfc3339-validator/rfc3339-validator-0.1.2.ebuild
new file mode 100644
index 000000000000..9f0280e058dd
--- /dev/null
+++ b/dev-python/rfc3339-validator/rfc3339-validator-0.1.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+inherit distutils-r1
+
+DESCRIPTION="A pure python RFC3339 validator"
+HOMEPAGE="https://github.com/naimetti/rfc3339-validator"
+SRC_URI="https://github.com/naimetti/rfc3339-validator/archive/v0.1.2.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/rfc3339-validator-0.1.2-remove-pytest-runner.patch"
+)
+
+distutils_enable_tests pytest